Members | Sign In
All Forums > Bugs Submission
avatar

No HDR lighting working for me...

posted Dec 04, 2012 20:38:40 by dragonguy
I'm loving ShaderMon so far, but I am unable to get any HDR lighting to work with my icon renderings. I've tried the defaults that ShaderMonger comes with to no avail, and also tried creating a simple custom lighting setup as well.

Also while switching to another HDR file (which I copied into the default IBL directory first) Maya would freeze entirely when I went to extract the shader from my object. No CPU usage, it just froze and I had to manually crash Maya from Task Manager.

I'm using Maya 2012 and Win7 x64, Phenom 1100T with 8GB of RAM and a Geforce 550Ti, if that helps.
page   1
6 replies
avatar
dabuel said Dec 08, 2012 21:41:58
Hi ,first, thanks for your feedback,

When using either "shadermonger" or "Custom" modes ,you should uncheck the "use lighting from template" box in the "extract shaders" options menu in order to use the current scene's render settings ( lighting setting include IBLs ).

the "shadermonger" mode does change a few attributes in the render global's but it sholdn't effect your ibl from rendering.

I just checked on my 2012 win7x64 and it showed the ibl just fine.
did you try it on a different scene ? perhaps test it on a simple sphere scene to see if your getting the results you are looking for.

I also checked the switching of the ibl and that worked fine as well, can you try to recreate that incident on a simple scene file and see what happens?? if the problem still occurs , please send me the file so i can take a look why this is...


let me know how it turned out.
and share something so we can see your cool icon ;)


Nadav
[Last edited Dec 08, 2012 21:44:52]
Administrator @ www.ShaderMonger.com
avatar
dabuel said Dec 09, 2012 00:05:08
OK , ive rechecked and yes, i see what you mean, in Custom mode when you want it to use the template lighing , it fails to work and brings in the current scenes IBL .

ill fix that asap. thanks for pointing this out!

i would suggest in the meantime to load the ibl into your current scene and extract Shaders.
[Last edited Dec 09, 2012 00:06:38]
Administrator @ www.ShaderMonger.com
avatar
dabuel said Dec 09, 2012 10:29:19
Hi , I rechecked it again and i think there is something wrong with your Custom scene.

in order for the custom scene to work properly you should follow the following guidelines:

everything in the scene (including the ibl node) should be under the group "shaderTemplateGroup"

everything in this group should have this ending "_shaderTemplate"
for instance :
mentalrayIbl1_shaderTemplate

the Create template from scene wizard ( right click on custom) does all that for you but its preferred that you wont do it from the customTemplate.mb but start it from a pre saved clean scene first.

send me your customTemplate.mb if you are still having problems and ill test it out on my machine.

let me know about the results.
cheers ,
Nadav Brill
Administrator @ www.ShaderMonger.com
avatar
Dragon Ninjaguy said Dec 10, 2012 19:33:21
Okay, I see now what I was doing wrong.

I wanted to just use the "ShaderMonger" setting, not Custom, Sphere, Cube, or Cone. This works fine except no matter which IBL I select from the top Lighting menu, none were showing up in my icon's rendering process, no matter if I checked "Use lighting From template" or not, in the actual Extract Shaders panel.

I tried this on a blank scene with a new shader from scratch, and as soon as I clicked "Add IBL to scene ->" it did in fact create a mental ray IBL node in my Outliner. So what I was experiencing previously was that I was trying to extract textures from my various arch/viz scenes themselves, and although the MR IBL node was being created, it was entirely occluded by my scene's walls and other geometry, and that's why it appeared that the IBL method for making icons wasn't working.

So what I should be doing is altering my Custom scene template, so that it renders the IBL proper? And from there, when I'm trying to extract shaders from my various projects into my Main Library, it will render the icon using the Custom template .mb file, correct? I'll try this a bit and see how it goes!
avatar
Dragon Ninjaguy said Dec 10, 2012 19:39:17
Hmm, when I try to do this with the Custom method, it says:

// Warning: Cannot add the following items to the set since the set has restrictions on membership: areaLight2_shaderTemplateShape areaLight2_shaderTemplate|_areaLight1_mrLoc //
// Warning: None of the items can be added to the set //
// Error: Too few arguments given. //
avatar
dabuel said Dec 12, 2012 10:03:31
send me your Custom file with HDR zipped/rarred to nadav@brillstudio.com
i'll have a look at it.

i rechecked and rechecked , as long as you dont re-edit the custom file ,it works perfectly.

Administrator @ www.ShaderMonger.com
Login below to reply: