Members | Sign In
All Forums > Bugs Submission
avatar

MacOSX Troubles

posted Feb 13, 2012 15:55:16 by Muttsy
I deployed ShaderMon to our artists and some of them use MacOSX, currently Snow Leopard, no Lion yet that I know of. All of the Windows users can use the plugin just swimmingly but our artists on the OSX side get the following warning/error.

source ShaderMon;
// Warning: file: /Volumes/Xsan/Assets/3D/MAYA/scripts/mel/ShaderMon.mel line 2536: Pixmap file render_AshliShader.png not found, using default. //
// Warning: file: /Volumes/Xsan/Assets/3D/MAYA/scripts/mel/ShaderMon.mel line 1713: No items found in: projz //


The ShaderMon GUI shows up just fine, but the Current Project directories never load and also the Main Library directories never load.

They have ShaderMonger MacOSX/Linux version 1.12 installed on their boxes.

They way I have this deployed is the ShaderMon.mel is on our Xsan drive, which is a network drive shared by all of our artists. I just use the maya.env to point each artists computer to this central script location. The ShaderLib directory, that came with the installer, was installed individually onto each artists computer, because for some reason when I had it on our network drive the mel script could not find the directory. But once I moved it to the individual computer your script found the directory and loaded just fine. Out of curiosity is the ShaderMon.mel for the Mac/Linux side different than the Windows side mel script? If so, that is my problem because the Macs are loading the ShaderMon.mel that came with the Windows version, though they are using the ShaderLib folder that came with the Mac/Linux version.

Thank you for your time.
page   1
2 replies
avatar
dabuel said Feb 14, 2012 10:24:37
Hi , first off all , yes, mac/linux based directory structures are different then Windows , so the scripts are different with their access to dirs.

that's why your OSX guys are not getting the project directories. try sourcing the OSX mel script on the macs localy and that should work just fine.
to make it more permanent , see if you can override the env setting with userSetupLocal.mel file under your scripts directory.

Shadermonger was written as a local plugin and not a network plugin due to the "shaderlib" Dir that it searches in the local scripts directory .

i think the best install for a case like yours is to install the mac's version individually on the devices and override the windows version.

Good luck ! let me know how it worked out.


Administrator @ www.ShaderMonger.com
avatar
Muttsy said Feb 14, 2012 15:42:43
I tried deploying the MacOSX version locally to my Mac users and I even took the Windows version down from the network to make sure the Macs were sourcing the right script. No luck, same error as before, seems it had no effect on the wackiness of the Mac operating system.

I am not sure if this makes that big of a difference but we are using Maya 2012x64 with the Subscription Advantage Pack and the latest Service Pack #2.
Login below to reply: